Degraded performance with loading login box

Incident Report for Frontegg

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 16:49 UTC

Monitoring

We have mitigated the issue by switching our CDN provider. We are now monitoring
Posted Oct 29, 2025 - 16:41 UTC

Identified

The issue has been identified as our CDN provider. We are working on mitigation with another provider
Posted Oct 29, 2025 - 16:15 UTC

Investigating

We are investigating reports on login load issues. Currently looks like related to our CDN provider. We will be providing updates shortly
Posted Oct 29, 2025 - 16:15 UTC
This incident affected: EU Region (Authentication APIs, Management Portal), US Region (Authentication APIs, Management Portal), Australia Region (Authentication APIs, Management Portal), Canada Region (Authentication APIs, Management Portal), and UK Region (Authentication APIs, Management Portal).