Elevated errors reported due to global incident with our WAF provider Cloudflare

Incident Report for Frontegg

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 13:23 UTC

Monitoring

We have deployed a DR for our Cloudflare instance. Systems should be back up again
Posted Nov 18, 2025 - 12:14 UTC

Update

We have deployed our DR to US and EU regions. Continue to work on other regions
Posted Nov 18, 2025 - 12:04 UTC

Update

Cloudflare has announced on global outage (https://www.cloudflarestatus.com/incidents/8gmgl950y3h7). We are continuing to work on DR and fallback mechanisms
Posted Nov 18, 2025 - 11:57 UTC

Identified

We have identified the issue as a global Cloudflare Outage and starting DR process
Posted Nov 18, 2025 - 11:47 UTC

Investigating

We are currently investigating reports of elevated errors originated by our WAF provider Cloudflare
Posted Nov 18, 2025 - 11:42 UTC
This incident affected: EU Region (Authentication APIs, Management APIs, Management Portal), US Region (Authentication APIs, Management APIs, Management Portal), Australia Region (Authentication APIs, Management APIs, Management Portal), Canada Region (Authentication APIs, Management APIs, Management Portal), and UK Region (Authentication APIs, Management APIs, Management Portal).