Service Outage

Incident Report for Frontegg

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 13:42 UTC

Monitoring

Update on the AWS incident from earlier: Amazon is still experiencing a global operational issue with CloudFront on their end, but we've implemented a workaround to bypass the affected component.

All regions are now back up and working normally.

We proactively rerouted to avoid the impacted path, so you shouldn't need to do anything on your side. We'll keep an eye on AWS's recovery and let you know if the situation changes.

If you notice anything still off, please flag it on our Slack — happy to help.
Posted Jul 16, 2026 - 12:09 UTC

Update

Hi all,
The Cloudfront issue still persists. However, we have implemented a workaround on our side.
We are rolling it out by region.
Australia, Canada, and the UK should be up and running now.
Posted Jul 16, 2026 - 11:34 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 11:33 UTC

Update

Hi all,
The Cloudfront issue still persists. However, we have implemented a workaround on our side.
We are rolling it out by region.
EU and US should be up and running now.
We will keep you posted.
Posted Jul 16, 2026 - 10:08 UTC

Update

Due to the global Cloudfront issue, some of our customers that are using custom domains v2 are still impacted. We are actively working to bypass Cloudfront service and bring those back to normal. We'll keep you posted.
Posted Jul 16, 2026 - 08:58 UTC

Identified

We've identified the cause of the disruption as an ongoing issue with our upstream cloud provider (AWS CloudFront). We are actively working internally as well to try and mitigate this until their service fully restored.
Posted Jul 16, 2026 - 08:56 UTC

Investigating

We are currently investigating this issue.
Posted Jul 16, 2026 - 08:06 UTC

Identified

We're currently investigating a service disruption affecting authentication and login across our platform. Our team is actively looking into the cause and working to restore service as quickly as possible.
We'll keep you posted.
Posted Jul 16, 2026 - 08:06 UTC
This incident affected: EU Region (Authentication APIs, Management APIs, Management Portal), US Region (Authentication APIs, Management APIs, Management Portal), Australia Region (Authentication APIs, Management APIs, Management Portal), Canada Region (Authentication APIs, Management APIs, Management Portal), and UK Region (Authentication APIs, Management APIs, Management Portal).