Degraded performance in US region - Partial Entitlements functionalities

Incident Report for Frontegg

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 13:34 UTC

Monitoring

We have identified a degraded performance in US region related to some Entitlements functionalities.

Our engineering team has resolved the issue and monitoring all service components.
We will provide regular updates as more information becomes available.
Posted Mar 23, 2026 - 11:43 UTC
This incident affected: US Region (Management APIs, Management Portal).